I have a Fraction class using keyword this in my constructor:
public Fraction(int numerator, int denominator)
{
this.numerator = numerator;
this.denominator = denominator;
adjustSigns();
if(this.denominator == 0 )
{
throw new FractionException(" Undefined Fraction ");
}
}
I also have a method :
public FractionInterface multiply(FractionInterface secondFraction)
{
Fraction second = (Fraction) secondFraction;
Fraction answer = new Fraction ((numerator * second.numerator), (denominator * second.denominator));
answer.reduceToLowestTerms();
return answer;
}
The above method works fine when I compile and run but so this this version:
public FractionInterface multiply(FractionInterface secondFraction)
{
Fraction second = (Fraction) secondFraction;
Fraction answer = new Fraction ((this.numerator * second.numerator), (this.denominator * second.denominator));
answer.reduceToLowestTerms();
return answer;
}
My question is which one is correct ?? If use the "this" keyword in my constructor do I also have to use it in my methods ?? Again, they both work fine and do what they are supposed to do but I want to know which way is the correct way. Thanks.
I think you have a bit of a confusion on how the "this" keyword works.
Let me give you an example:
This
is the same as:
Which of course for the second one would be easier to put if we do it like this:
Using
this
explicitly is mandatory if you wish to distinguish between a local variable and a member of the same name. Otherwise, it is optional.Your constructor won't assign the passes values to the instance members without the
this.
prefix, since the method arguments would hide the instance members. If you give the arguments different names, you can do without thethis.
:Both
multiply
versions are the same.Both the cases you mentioned will work fine.
Use of
this
is a good practice as its more readable due to our english mindset, When we saythis.some_variable
, we get a mental image of some_variable inside the current classthis
keyword is also helpful in avoiding variable shadowing