Parameter naming: filename or fileName?

2019-02-03 21:08发布

I try to be grammatically correct in my naming*. I've always used filename instead of fileName. The java convention also seems to use this, but FxCop prefers fileName.

There's a discussion on WikiPedia about it. The more I read, the more I feel I'm right (which is quite usual! :) ). Does anyone have a definitive answer or is this merely something subjective?

* I just hope there are no grammar errors in this post!

9条回答
贼婆χ
2楼-- · 2019-02-03 21:42

I think the answers here are spanning two issues.

  • 'FileName' vs 'Filename' (should 'name' be a separate word)

    and

  • 'fileName' vs 'FileName' (should first character be lower case).

In most cases, I prefer to treat this word as a single whole word 'filename'. I also prefer starting variables/methods with lower case for easier code completion menu navigation.

I guess the issue of camel case is here too which I think should be used to distinguish multi-word names.

查看更多
欢心
3楼-- · 2019-02-03 21:44

Lower camel case is recommended for fields and parameters.

Example 1:

fileName // for fields, parameters, etc.
FileName // for properties, class names, etc.

Generally, fileName is used and NOT filename; you can verify that by reading source code of open source stuff created by Microsoft, such as Enterprise Library.

Reasons:

  1. The main point behind this is that names are more readable in this case.
  2. Also this approach adds consistency when several parameters (fields, variables..) are used in the same method (class..) and the with same prefix "file", as demonstrated below:
  3. ...there are a few other reasons, but they are more subjective.

Example 2:

fileName, fileSize... // instead of filename AND filesize

See also:

For a full set of naming convention rules, I recommend checking this book:

And also check some stuff at IDesign.net

查看更多
狗以群分
4楼-- · 2019-02-03 21:48

Filename ~ an identifying name given to an electronically stored computer file, conforming to limitations imposed by the operating system, as in length or restricted choice of characters.

In the past this was considered two words but now is defined as one word so

var filename = ......

if it was two words it would be

var fileName = ....

查看更多
够拽才男人
5楼-- · 2019-02-03 21:51

There can be no real right or wrong here.

This is something that is purely subjective and relates completely to the community you are working in. If FxCop and StyleCop and the .net code that you regularly encounter is using fileName, then use fileName. If it is using something else, then use whatever that is.

Your first priority should probably be to be consistent to the pattern in your own code and then consistent with your community.

In this particular case, .net Reflector shows a lot of .net code using fileName so I would go with that pattern personally.

If you were in the java world and running PMD and checkstyle and their apis made frequent use of filename, then I would go with that.

In addition to the wikipedia naming article, there is also The Practice of Programming by Kernighan and Pike. The first chapter in it touches on a lot of naming and code consistency issues.

查看更多
虎瘦雄心在
6楼-- · 2019-02-03 21:52

As far as I am concerned,

thisIsMuchMoreReadable than readingthis.

查看更多
仙女界的扛把子
7楼-- · 2019-02-03 21:52

If you are writing c/c++ there is a strong tendency to use names that people can actually read; i.e. filename is good, and so is yet_another_file_name (assuming you are not considering filename as a proper english word - I usually do).

See google coding standards

查看更多
登录 后发表回答