What is the recommended approach to naming base classes? Is it prefixing the type name with "Base" or "Abstract" or would we just suffix it with "Base"?
Consider the following:
type: ViewModel
e.g. MainViewModel, ReportViewModel
base class: BaseViewModel
or ViewModelBase
or AbstractViewModel
Also consider:
type: Product
e.g. VirtualProduct, ExpiringProduct
base class: BaseProduct
or ProductBase
or AbstractProduct
Which do you think is more standard?
class Entity : EntityBase
{
}
or
class Entity : BaseEntity
{
}
Personally, I would recommend against adding the word base at all. You never know when you'll have to change the code around and it won't be the base object anymore. That being said, we have done this in the past, we prefixed the word Base on the front. It seems to flow better.
If you're talking about virtual base classes, Microsoft's standard is ClassnameBase (like CollectionBase.)
Always think about alphabetizing when you name stuff. I really don't like looking at a SQL server and every stored procedure is named usp[something]. Along the same lines, don't overuse Get and Set as leading names for a function. Instead of GetItems or PlaceOrder, think about naming them as ItemsGet or OrderPlace.
So, in general, ClassnameBase / EntityBase would be a better choice.
We use BaseEntity, but I think it your own preference. I frequently see the other.
Just be consistent within your context, be that your project, namespace or if possible, your team. Different conventions are worse than a bad convention IMHO.
I think its a matter of choice. I'd say if you are creating a lot of base classes then perhaps it is better to go with BaseClassname always because that way you can ALWAYS find out what base classes you can start using by just typing Base and getting the rest of the help from Intellisense. What if you had 20 Base classes and you added Base as suffix and you forgot what was the name of the base class? Do you want to create a class diagram first from VS and find out what base classes are available? It's alright to name them ClassBase when it is just one or two classes.
Same goes for decision between GetItems and ItemsGet function. I'd say for readability's sake atleast - go for GetItems. Follow the conventions :)
None of the above. Consider what purpose your base class provides; name it that. For example, the base class of Automobile and Bicycle could be Vehicle.
If you're creating base classes just to have a base class of one class, and with no purpose or reason other than that, you're probably doing something wrong.