Are there any 'harmonious' ways to get the class name from ES6 class instance? Other than
someClassInstance.constructor.name
Currently I'm counting on Traceur implementation. And it seems that Babel has a polyfill for Function.name
while Traceur doesn't.
To sum it all up: there was no other way in ES6/ES2015/Harmony, and nothing is expected ATM in ES.Next.
It may provide useful patterns for unminified server-side applications but is unwanted in applications meant for browser/desktop/mobile.
Babel uses core-js
to polyfill Function.name
, it should be loaded manually for Traceur and TypeScript applications as appropriate.
someClassInstance.constructor.name
is exactly the correct way to do this. Transpilers may not support this, but it is the standard way per the specification. (Thename
property of functions declared via ClassDeclaration productions is set in 14.5.15, step 6.)Getting class name directly from class
Previous answers explained that
someClassInstance.constructor.name
works just fine, but if you need to programmatically convert class name into a string and don't want to create an instance just for that, remember that:And, since every function has a
name
property, another nice way to get a string with your class name is to just do:What follows is a good example of why this is useful.
Loading web components
As the MDN documentation teaches us, this is how you load a web component:
Where
YourComponent
is a class extending fromHTMLElement
. Since it is considered good practice to name your component's class after the component tag itself, it would be nice to write a helper function that all your components could use to register themselves. So here's is that function:So all you need to do is:
Which is nice because it's less error-prone than writing the component tag yourself. To wrap it up, this is the
upperCamelCaseToSnakeCase()
function:As @Domenic says, use
someClassInstance.constructor.name
. @Esteban mentions in the comments thatThus, to access the class name statically, do the following (this works with my Babel version BTW. According to the comments on @Domenic your mileage may vary).
Update
Babel was fine, but uglify/minification did end up causing me problems. I am making a game, and am creating a hash of pooled Sprite resources (where the key is the function name). After minification, every function/class was named
t
. This kills the hash. I am usingGulp
in this project, and after reading the gulp-uglify docs I discovered there is a parameter to prevent this local variable/function name mangling from happening. So, in my gulpfile I changed.pipe($.uglify())
to.pipe($.uglify({ mangle: false }))
There is a trade-off of performance vs readability here. Not mangling the names will result in a (slightly) larger build file (more network resources) and potentially slower code execution (citation needed - may be BS). On the other hand, if I kept it the same I would have to manually define
getClassName
on every ES6 class - at a static and instance level. No thanks!Update
After the discussion in the comments, it seems like avoiding the
.name
convention in favor of defining those functions is a good paradigm. It only takes a few lines of code, and will allow full minification and generality of your code (if used in a library). So I guess I change my mind and will manually definegetClassName
on my classes. Thanks @estus!. Getter/Setters are usually a good idea compared to direct variable access anyways, especially in a client based application.