I'm using nested resources, however i come across controller names that should be more descriptive.
For instance i have a controller ProductsController
and ImagesController
resources :products do
resources :images
end
This works fine, but later i might need to use the ImageController
for other than products images, therefore it should be named ProductsImagesController.
But how can i specify the controller name on resources()
without falling back to something ugly like:
match 'products/images' => 'products_images#index'
match 'products/images/new' => 'products_images#new'