Intel HAXM on macOS high sierra (10.13)

2019-03-09 12:44发布

问题:

Is there any way of using Android emulator on High Sierra (10.13)?

When I run

./HAXM\ installation -u

It says:

HAXM silent installation only supports macOS from 10.8 to 10.12 !

回答1:

The command line installation doesn't work and gives unsupported mac os version error, while the installation through IntelHAXM_6.2.1.mpkg works but kext is not loaded due to "Approved Kernel Extension Loading" changes,

So you will need to allow the extensions from Intel and restart your mac, then launch the emulator like from inside Android Studio,

To enable go to System Preferences > Security & Privacy as shown in the screenshot:



回答2:

I was able to install Intel HAXM drivers on my Mac using the instructions provided in this post. There might be other (better) solutions to this, but I have successfully managed to start the emulator this way. Essentially you need to disable the security protection on kext before trying to install the HAXM drivers. To do that, you need to run

csrutil enable --without kext

But, note that this command will only work on Recovery OS, which means that you need to restart your Mac and hold command + R until the Apple logo is displayed. Next, you need to go to Utilities > Terminal and run the csrutil command. Restart your Mac and log in, then go here to download the latest Intel HAXM driver. Unzip if needed, edit the silent_install.sh file and search for the 10.12 OS version. You will find it on the line which should look like this

for v in 10.8 10.9 10.10 10.11 10.12

You need to add the 10.13 version after 10.12 (separated by space, just like the rest). Save the file and open a Terminal at this location. Run ./silent_install.sh and that should be it. To be sure it works, you can also run sudo kextload -bundle-id com.intel.kext.intelhaxm.

Now your emulator should work.

In order to re-enable the kext security protection, you need to restart your Mac in Recovery OS, open a Terminal window and run csrutil enable.



回答3:

Intel Corporation just fixed it and released HAXM for macOS Sierra and macOS High Sierra, just download the zip, and execute the .dmg file, then restart Android Studio. It worked for me, hope it works for you too.

Intel Link for the download : https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager-end-user-license-agreement-macosx



回答4:

Use the new Hypervisor.Framework support on macOS.

Add this line in ~/.android/advancedFeatures.ini (create this file if it doesn't exist already).

HVF = on

Issue answered here: https://issuetracker.google.com/issues/62395878#comment7

That's worked for me.

Also you can be updated with Intel HAXM as they fixed this error.

Download HAXM latest version here (Restart macOS Required):

https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager-end-user-license-agreement-macosx

Hope it help.



回答5:

Download this https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager-end-user-license-agreement-macosx and install .dmg then restart pc.This worked for me.



回答6:

You can use Google's 6.2.1's silent_installer.sh to properly install HAXM on High Sierra:

https://dl.google.com/android/repository/extras/intel/haxm-macosx_r6_2_1.zip

Otherwise use Android Studio's SDK Manager to download and install it for you:

This was not introduced until 6.2.1(Google Distribution only) which looks like a hotfix from the 6.2.0 version which would throw the following message:

HAXM silent installation only supports macOS from 10.8 to 10.12!

If you don't want to use HAXM, you can use the Hypervisor.Framework by ensuring you have installed Android Emulator 26.1.3

Documentation

The emulator is now fully compatible with macOS 10.13 High Sierra through either Hypervisor.Framework or HAXM 6.2.0.

https://developer.android.com/studio/releases/emulator.html#26-1-3



回答7:

Try using Hypervisor.Framework as mentioned in this post.

https://issuetracker.google.com/issues/62395878



回答8:

To verify that Intel HAXM is running, open a terminal window and execute the following command:

kextstat | grep intel

If Intel HAXM is operating correctly, the command will show a status message indicating that the kernel extension named com.intel.kext.intelhaxm is loaded.

Try to stop and stat again HAXM., than verify it works correctly.

To stop Intel HAXM, use the following commands:

sudo kextunload -b com.intel.kext.intelhaxm

To start Intel HAXM, use the following commands:

sudo kextload -b com.intel.kext.intelhaxm


回答9:

If you have already installed the latest Intel HAXM Manager (v6.2.1) then re-install it and restart your computer. It will fix the emulator problem. You will be able to run emulators again. Here is the link: https://software.intel.com/en-us/articles/intel-hardware-accelerated-execution-manager-intel-haxm



回答10:

I had to go to System Preferences > Security & Privacy, click the unlock button, and a message will pop up asking to allow Intel to run. After that, HAXM ran on High Sierra.