Java's standard libraries seem to use camelCase for method names. Native functions like nanoTime()
are no exceptions.
If so, why is System.arraycopy
not camelCased?
Is there something special about System.arraycopy
?
Java's standard libraries seem to use camelCase for method names. Native functions like nanoTime()
are no exceptions.
If so, why is System.arraycopy
not camelCased?
Is there something special about System.arraycopy
?
It's been in Java for before v1.0 was released - so my guess is that it predates the naming conventions, and it was missed in a sweep of the API when the naming conventions were decided.
(In other news, NullPointerException
should be called NullReferenceException
.)