I have docker desktop installed in mac. So in order to start docker, I open applications and find docker. Then I can see a docker icon at the topbar. later I can run docker commands from the command line.
My question is how do I start the docker itself from command line?
Googling fetches me results on how to start a container from command line :|
On macOS
you'd use launchctl
:
It's unclear which service you are actually intending to run, although the equivalent to service
or systemctl
on Linux
is launchctl
on macOS
(eg. running docker registry with launchd
):
Copy the Docker registry plist into place:
plutil -lint registry/recipes/osx/com.docker.registry.plist
cp registry/recipes/osx/com.docker.registry.plist ~/Library/LaunchAgents/
chmod 644 ~/Library/LaunchAgents/com.docker.registry.plist
Start the Docker registry:
launchctl load ~/Library/LaunchAgents/com.docker.registry.plist
Restart the docker registry service
launchctl stop com.docker.registry
launchctl start com.docker.registry
Unload the docker registry service
launchctl unload ~/Library/LaunchAgents/com.docker.registry.plist
↳ Run the Docker Registry under launchd